Gutenberg Blocks, add block button greyed out/inactive for Pages and Posts

I was going to give the Blocks editor another try.
But for Pages, and for Posts, it doesn't work, there's no blocks available, the plus button is greyed out:

If I click the tre vertical dots on the right and select Block Manager, there's lots of blocks, and they're all enabled ...
And the Blocks editor actually works for widgets stuff ... Any idea what to check or do?
(This is a Multisite WP installation, latest stable WP version.)


  • Have you had any other page builder plugin on the site that might have disabled/conflicted with this?

  • flipsflips OG
    edited December 2021

    Shouldn't be any conflict, @Mr_Tom. Has LiveCanvas installed, and a deativated Divi. (It's a lab site, I activate and deactivate stuff quite often.)

    Found the answer on StackExchange (thank you DuckDuckGo): :)
    Go to Users > Your Profile and uncheck "Disable the visual editor when writing"

    Thanked by (1)Ympker
  • Ah, glad it got sorted.

    Figured it would be something simple but I have known some plugins leave "issues" even after deactivating hence leaning that way initially.

    Thanked by (1)flips
Sign In or Register to comment.