Owncloud trusted_domain issue after upgraded from 10.10 to 10.11[SOLVED]

edited November 4 in Help

After updated my Owncloud container from 10.10 to 10.11, it indicates follow error

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domains" setting in config/config.php. An example configuration is provided in config/config.sample.php
  1. Access from 127.0.0.1:8080 via ssh remoting also get same error
  2. Change the variable trusted_domains in config.php won't work

Anyone gets the same problem?

Bid service transfer of bandwagonhost and spartanhost

Tagged:

Comments

  • BochiBochi OG
    edited November 3

    Sounds to me like maybe your proxy is not forwarding the information about the host correctly and or a wrong trusted_proxies setting.
    There was even a change regarding this included in the 10.11 release (see: https://github.com/owncloud/core/pull/40148).

  • @Bochi said:
    Sounds to me like maybe your proxy is not forwarding the information about the host correctly and or a wrong trusted_proxies setting.
    There was even a change regarding this included in the 10.11 release (see: https://github.com/owncloud/core/pull/40148).

    I double checked the log of owncloud & nginx, the domain info has been handled correctly.

    It has been solved by adding the env OWNCLOUD_TRUSTED_DOMAINS rather than modify config.php

    It should a bug I suppose.

    Bid service transfer of bandwagonhost and spartanhost

Sign In or Register to comment.