IPV6 issue

RazzaRazza OG
edited October 2021 in Help

I've been recently enabling IPV6 on all my server that got native IPv6 the only server I had it configured on before was my mail server.

Ever server the IPv6 is working fine except for one that got a werid issue on boot IPv6 doesn't work until I ping the gateway IP or randomly after about 5-10 mins after boot it starts working after that it seem to work fine.

Just wondering if anyone who understands IPv6 and networking better then me got any ideas what might be causing the issue.

I've included the relevant part of network config on Debian

 iface ens192 inet6 static
address 2a00:****:****:77:1:ea7:dead:beef/64
gateway fe80::1

Comments

  • edited November 2021

    Is your provider using Virtualizor? I have no idea what's going on internally, but that seems to be a common issue on Virtualizor-based host nodes.
    I usually put a cronjob on these servers which sends a ping on every reboot as a workaround. Make sure to add some delay to avoid the ping being executed before the network's up.

    Thanked by (1)Razza

    Need a free NAT LXC? -> https://microlxc.net/

  • Mr_TomMr_Tom Hosting ProviderOG

    @Brueggus said: Is your provider using Virtualizor? I have no idea what's going on internally, but that seems to be a common issue on Virtualizor-based host nodes.

    No IPv6 on boot?

    @Razza is this a VPS or dedi? You could try adding pre-up modprobe ipv6 just after the inet6 static line just incase it's that.

    Thanked by (1)Razza
  • Thanks @Brueggus I've added added ping as post-up on the interface that seem to fix it, it's not a Virtualizor vm I got doing it it's VMware one, must be some werid bug or setup on the provider side since you shouldn't have to ping the gateway to get it working.

    @Mr_Tom it's a VMware VM I tried adding that didn't do anything am pretty sure the kernel module get enabled automatically anyway.

  • ehabehab Content Writer
    edited November 2021

    if it makes you feel better @vyas can do the pings for you. he pings very hard.

Sign In or Register to comment.