Roundcube - "Out of Office" function not working properly?

YmpkerYmpker OGContent Writer

Hello there,
I am trying to configure the "Out of Office" function from Roundcube to auto-respond to messages I receive during Christmas break. The screenshot below shows the current configuration I have setup, however it appears to not be working. I tried sending several emails from different email accounts to my Shared Hosting account's email, but the auto-respond feature just wouldn't work. Anything, I have done wrong in the settings? I am using MyW Shared Hosting. Just didn't want to Open a Ticket on @MikePT just a couple days before Christmas. It isn't urgent either. I have managed without an auto-responder before. Just wondering why it won't work. Any ideas?

Kind regards,
Ympker

Comments

  • Roundcube it self doesn't send the autoreply, I believe it just create the filters server side that actually does it.

    Possibly reason might be the backend is not configured correctly for out of office to work, or you might need to configure it via web hosting panel instead of RC, I don't use DA so not sure if roundcube management of that feature actual works.

    Thanked by (3)Ympker lentro Janevski
  • YmpkerYmpker OGContent Writer

    @Razza said:
    Roundcube it self doesn't send the autoreply, I believe it just create the filters server side that actually does it.

    Possibly reason might be the backend is not configured correctly for out of office to work, or you might need to configure it via web hosting panel instead of RC, I don't use DA so not sure if roundcube management of that feature actual works.

    Thanks for explaining, mate :) In that case I probably will have to open a ticket with @MikePT , then :)

  • @Ympker said:
    Hello there,
    I am trying to configure the "Out of Office" function from Roundcube to auto-respond to messages I receive during Christmas break. The screenshot below shows the current configuration I have setup, however it appears to not be working. I tried sending several emails from different email accounts to my Shared Hosting account's email, but the auto-respond feature just wouldn't work. Anything, I have done wrong in the settings? I am using MyW Shared Hosting. Just didn't want to Open a Ticket on @MikePT just a couple days before Christmas. It isn't urgent either. I have managed without an auto-responder before. Just wondering why it won't work. Any ideas?

    You might ask @MikePT to check whether the managesieve plugin for Roundcube is installed.

    It can be a little tricky to get sieve support working properly on Dovecot, and the managesieve plugin for Roundcube will only work if sieve support is otherwise working properly on Dovecot.

    Thanked by (1)Ympker

    "A single swap file or partition may be up to 128 MB in size. [...] [I]f you need 256 MB of swap, you can create two 128-MB swap partitions." (M. Welsh & L. Kaufman, Running Linux, 2e, 1996, p. 49)

  • For the old-school way, see man vacation, but this may not work on shared hosting.

    Thanked by (1)Ympker

    "A single swap file or partition may be up to 128 MB in size. [...] [I]f you need 256 MB of swap, you can create two 128-MB swap partitions." (M. Welsh & L. Kaufman, Running Linux, 2e, 1996, p. 49)

  • Mr_TomMr_Tom Hosting ProviderOG
    edited December 2021

    As mentioned, it won't be roundcube doing the OOO reply, it will just be trying to set it up.

    As it's shared just open a ticket - or just leave it off. It's Christmas time, the emails can wait ;) (edit, I only say that as I wish I could do that - I won;t be ignoring any emails lol)

    Thanked by (1)Ympker
  • YmpkerYmpker OGContent Writer
    edited December 2021

    You might ask @MikePT to check whether the managesieve plugin for Roundcube is installed.

    It can be a little tricky to get sieve support working properly on Dovecot, and the managesieve plugin for Roundcube will only work if sieve support is otherwise working properly on Dovecot.

    I opened a ticket with him and see what/if he'll reply :) Thanks mate!

    @angstrom said:
    For the old-school way, see man vacation, but this may not work on shared hosting.

    Hmmm... MyW allows SSH access sooo... ;)

    @Mr_Tom said:
    As mentioned, it won't be roundcube doing the OOO reply, it will just be trying to set it up.

    As it's shared just open a ticket - or just leave it off. It's Christmas time, the emails can wait ;) (edit, I only say that as I wish I could do that - I won;t be ignoring any emails lol)

    Thanks for replying. Yeah, I opened a ticket with Mike, but I don't really expect a reply before Christmas is over :P Maybe for the next year I'll have it setup. Hope you don't get swamped with work :)

    Thanked by (1)Mr_Tom
  • Mr_TomMr_Tom Hosting ProviderOG

    @Ympker said: Hope you don't get swamped with work

    Cheers! To be fair we're never bombarded with tickets, but I'll be taking most of the "on call" time to give others time off.

    Interested to see the outcome - I use roundcube a lot and didn't know it could configure OOO on behalf of the MTA so it's interesting to see.

    Thanked by (1)Ympker
Sign In or Register to comment.